Jump to content
Jagware
Sign in to follow this  
stabylo

Jag Sur Cate Tv, Synchro & Couleurs

Recommended Posts

stabylo    0

[english]

I just tested my new S-video cable to plug my Jaguar on my TV tunner board. Everything is okay in 50Hz mode (S-video PAL N mode, in my case), but if I stay in PAL N, the TV borad can't synchronise when the JAg is in 60Hz. PAL M and NTSC M do synchronize, but color encoding is different, so I have bkack&white display :huh:

 

If there is a mean to solve that with a bit of electronics I'd be glad to know! :) (for the moment I have 60 Hz only in black & white)

 

[french]

il y a quand même une très legère différence entre les 2 models au niveau frequence dont certaines TV/moniteur n'apprecient pas et aussi pour les sorties SVHS et Composite où le filtre n'est pas exactement le même (les yeux américains ne vois pas les même choses :P)(:wacko:)
Je fais un nouveau fil pour ma question spécifique à ce sujet.

 

Je viens de tester mon nouveau câble S-video pour brancher ma jag sur ma carte télé. Tout va bien en 50 Hz (S-video PAL N pour ma carte télé), mais si je reste en PAL N, la carte n'arrive pas à se synchroniser sur l'image de la console en 60Hz. Les modes PAL M et NTSC M de ma carte se synchronisent convenablement, mais le codage des couleurs est différent donc j'ai du noir et balnc. :huh:

 

S'il y a moyen d'y remédier avec un petit montage et quelques soudures, je suis preneur! :) (pour l'instant, je n'ai du 60Hz qu'en noir et blanc)

Share this post


Link to post
Share on other sites
GT Turbo    3

Zerosquare, notre 'video man' est demander chez Stabylo, voire SCPCD (Mais faut laisser SCPCD travailler sur la JagCF ;) )

 

 

GT :poulpe:

Share this post


Link to post
Share on other sites
Orion_    1

avec ma freebox j'avais le même probleme, impossible d'avoir une image couleur en svideo. on m'a dit que la xbox n'etait pas adapté svideo et qu'il fallais utiliser une sortie composite (RCA), ça a réglé le probleme.

Share this post


Link to post
Share on other sites
Zerosquare    10

Je n'ai pas testé, mais d'après le schéma c'est la résistance R19 qui détermine le mode d'encodage des couleurs. Elle est reliée à la patte 19 du MC13077. C'est le même principe que pour le switch 50/60 Hz, sauf que c'est le contraire : résistance présente en mode NTSC, absente en mode PAL. Tu devrais donc pouvoir obtenir un switch PAL 50 Hz/NTSC 60 Hz en enlevant cette résistance si elle est présente, et en reliant la patte 19 au côté non utilisé de l'interrupteur.

 

EDIT : ce n'est pas suffisant pour obtenir du NTSC standard, car la fréquence du quartz utilisé pour la sous-porteuse couleur doit aussi être changée (Y1 sur le schéma ; 14,31818 MHz pour le mode NTSC, ils omettent de mentionner la valeur différente pour le mode PAL). En laissant le quartz d'origine des Jaguar européennes (17.734475 MHz), on devrait obtenir du "NTSC 4.43" si je ne me plante pas. Reste à savoir si ta carte le supporte ou pas...

Share this post


Link to post
Share on other sites
stabylo    0
avec ma freebox j'avais le même probleme, impossible d'avoir une image couleur en svideo.
taratata, la freebox elle marche chez moi en s-video B) Les vendeurs m'ont induit en erreur et m'ont fait acheter un méga cable un peu cher, mais google mon ami m'a dit que ce n'était qu'une question de réglage du pilote. Pour le mien, il fallait par exemple lui dire que c'était du PAL M ou du PAL N, je sais plus exactement mais google est là pour le reste. (fin du HS :whistling: )

 

pour mon petit souci à moi, j'ai remplacé mon pilote hauppauge tout naze par un fougueux btwincap et j'ai mes couleurs et mes 50 fps nickel (c'est miex qu'avant parce que je peux utiliser ktv maintenant) :yes:

 

Pour le 60Hz par contre c'est un pb de synchro. La carte télé se synchronise sur une frame sur deux, donc j'ai le plus souvent ~30 fps. La taille de capture semble devoir être 640x480, mais modifier ce paramètre n'arrange pas mes affaires, j'ai des morceaux d'images en bas, certainement dus au fait que mon bt878 loupe des signaux de synchro.

 

Je pense cependant que tout ça n'est qu'une question de pilote parce que j'avais la synchro en n&b dans certains modes avec les pilotes hauppauge, et maintenant avec btwincap j'ai les couleurs mais pas la synchro.

 

Comment puis-je bidouiller les paramètre de mon bt878 pour qu'il accepte le 60 Hz de la jag?

zerosquare, j'ai vu que tu t'étais fait un pilote sur mesure pour ta carte TV, comment t'y es tu pris?

Share this post


Link to post
Share on other sites
Zerosquare    10
Comment puis-je bidouiller les paramètre de mon bt878 pour qu'il accepte le 60 Hz de la jag?

zerosquare, j'ai vu que tu t'étais fait un pilote sur mesure pour ta carte TV, comment t'y es tu pris?

Bouah, juste quelques centaines d'heures à lire des docs incomplètes et imbuvables, à tester des trucs pas-à-pas, à rebooter le PC parce qu'un bug dans le code l'a fait complètement planter (ça pardonne pas les bugs dans les drivers :D )... la routine quoi :whistling: .

Même si l'envie te prenait de faire pareil, je ne pourrais pas t'aider beaucoup, étant donné que le chipset de ma carte n'est pas un BT8x8. Au cas où, y'a un vieux vieux programme pour modifier les registres du BT qui traîne sur mon disque dur (je ne sais même pas s'il marche sous Win2000/XP), fais-moi savoir si ça t'intéresse.

 

Il y a deux aspects qui nous intéressent pour les signaux vidéos : les timings (50 ou 60 Hz) et l'encodage des couleurs (PAL ou NTSC). Pour faire simple, les signaux vraiment standardisés sont le PAL 50 Hz et le NTSC 60 Hz. Or, sur une Jag européenne switchée en 60 Hz avec la méthode "classique", on se retrouve avec du PAL 60 Hz, un mélange des deux. Ça peut fonctionner sur certaines TV et cartes, mais il n'y a pas de garantie... (si le driver le permet, as-tu essayé toutes les variantes possibles du PAL et du NTSC ?)

 

Après, je ne peux pas te dire à froid s'il est possible de reprogrammer le BT8x8 pour qu'il accepte ce genre de signaux... c'est probable, mais il faudrait se pencher sur la doc pour savoir comment. Si tu veux des infos plus détaillées sur les formats, cette page est pas mal ; pour les docs du circuit, c'est ici.

Share this post


Link to post
Share on other sites
Orion_    1
taratata, la freebox elle marche chez moi en s-video B) Les vendeurs m'ont induit en erreur et m'ont fait acheter un méga cable un peu cher, mais google mon ami m'a dit que ce n'était qu'une question de réglage du pilote. Pour le mien, il fallait par exemple lui dire que c'était du PAL M ou du PAL N, je sais plus exactement mais google est là pour le reste. (fin du HS :whistling: )

bah moi dans tout les modes ca marchais pas :/

Share this post


Link to post
Share on other sites
Zerosquare    10
bah moi dans tout les modes ca marchais pas :/
À cause de l'affectation des broches sur la prise péritel, le mode composite et le mode S-vidéo sont mutuellement exclusifs, et ça donne une image monochrome ou avec de très mauvaises couleurs si tu branches du S-vidéo quand le mode composite est actif, et vice-versa. Tu es sûr qu'il n'y a pas une option dans un des menus pour choisir ? Parfois aussi le S-vidéo n'est disponible que sur l'une des sorties péritels (sur mon décodeur câble par exemple, c'est uniquement sur la prise "magnétoscope"). En tout cas ça me surprendrait que la Freebox ne le permette pas, la différence de qualité entre S-vidéo et composite étant quand même visible.

Share this post


Link to post
Share on other sites
stabylo    0
Bouah, juste quelques centaines d'heures à lire des docs incomplètes et imbuvables, à tester des trucs pas-à-pas, à rebooter le PC parce qu'un bug dans le code l'a fait complètement planter (ça pardonne pas les bugs dans les drivers :D )... la routine quoi :whistling: .
lol :lol: Ah ça oui les bugs sur les pilotes ça pardonne pas. Je vois ça avec le pilote opensource que j'y ai mis. Mon win2k il me fait plein d'écrans bleus maintenant :(

Au cas où, y'a un vieux vieux programme pour modifier les registres du BT qui traîne sur mon disque dur (je ne sais même pas s'il marche sous Win2000/XP), fais-moi savoir si ça t'intéresse.
ok fais péter, ça peut toujours servir ;)

Pour faire simple, les signaux vraiment standardisés sont le PAL 50 Hz et le NTSC 60 Hz. Or, sur une Jag européenne switchée en 60 Hz avec la méthode "classique", on se retrouve avec du PAL 60 Hz, un mélange des deux.
Ok, ça confirme ce que je me disais. Comme c'est un signal hybride, ont peut pas apréhender le signal avec des réglages classiques.

Ça peut fonctionner sur certaines TV et cartes, mais il n'y a pas de garantie... (si le driver le permet, as-tu essayé toutes les variantes possibles du PAL et du NTSC ?)
Oui, j'ai essayé la vingtaine de réglages disponibles. Il y en a bien un qui s'appelle PAL 60 et qui avait l'air prometteur, mais j'ai des restes de signal video en bas de l'image capturée et K!tv me dit qu'il n'affiche que 30 img/s au lieu de 60. Pas super intéressant...

Après, je ne peux pas te dire à froid s'il est possible de reprogrammer le BT8x8 pour qu'il accepte ce genre de signaux... c'est probable, mais il faudrait se pencher sur la doc pour savoir comment. Si tu veux des infos plus détaillées sur les formats, cette page est pas mal ; pour les docs du circuit, c'est ici.
Merci pour ces détails Zerosquare!

 

 

En tout cas ça me surprendrait que la Freebox ne le permette pas, la différence de qualité entre S-vidéo et composite étant quand même visible.
Oui, surtout que chez moi ma freebox fonctionne branchée en s-video sur mon hauppauge. Mais il peut y avoir une question de version de freebox? (j'ai la v4) :huh:

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×